Some users may experience issues with the Veradigm FollowMyHealth application.

Incident Report for Veradigm FollowMyHealth

Resolved

This incident has been resolved.
Posted Jun 15, 2026 - 19:53 UTC

Monitoring

We have implemented a fix for the issue impacting Veradigm FMH invitations and are monitoring the results.
Posted Jun 15, 2026 - 17:16 UTC

Investigating

We are aware of an issue impacting Veradigm FMH invitations. We are working to resolve the issue as quickly as possible.
Posted Jun 15, 2026 - 16:23 UTC
This incident affected: Veradigm FollowMyHealth.